Блог // Установка Drush 8 с помощью Composer

Drupal разработка, Пт, 04/22/2016 - 08:44

На текущий момент на всех наших серверах установлена версия Drush 5. Эта версия умеет работать с Drupal 6/7. Для работы с Drupal 8 нужно установить новую версию Drush. Для этого нужно:

1. Выполнить команду:

composer global require drush/drush:dev-master

2. Открыть на редактирование файл ~/.bashrc и добавить в конец файла строку:

alias drush8="php ~/.composer/vendor/drush/drush/drush"

3. Выйти из командной строки и войти заново чтобы применились изменения:

exit

После входа Drush 8 будет доступен для вас из консоли по команде:

drush8